You have PHP version: 5.2.17 installed. This theme requires atleast PHP Version 5.3.0. Please contact your webhost for more information. You can revert back to your old theme by going to your FTP server and deleting the theme you just activated.